Introduction Last updated: 2020-7-21

This section gives you a quick overview about the basic ideas of InterpretBank.

The user interface

The user interface is divided into three main areas: the Menubar, the Entry fields and the Table.

There are several views:

  • the EDIT view, to create your glossary
  • the DOCUMENT view, to create your glossary while working on preparatory documents
  • the MEMORIZATION view, to learn a glossary
  • the BOOTH view, to look up terms in the booth

The entry fields

Entry fields are used to write and edit terms. As default, only the basic fields "term" are shown.

To add extra information, such as abbreviations etc, use the dedicated fields called "Notepad", "Info" and "Abb". You can show or hide these fields using the two small icons on the right of the menubar.

The fields Info (general info) and Abb (abbreviation) are related to the term in a specific language. The field Notepad contains general info that apply to that record in any language.

The table

The table is used to visualize an entire glossary or the result of a search. The table is not editable. To edit a record, click on a row to activate the desired record and edit it in the entry fields above. You control the table by right clicking of the mouse on it. A pop up menu will be shown. For example you can move columns to the right or the left, show or hide columns, and so forth.

The table uses a paging feature: it will show you a fix amount of records (by default 10). You can move forth and back using the paging function on the bottom of the table. The pagin feature is key to make InterpretBank responsive.

How glossaries are organized

InterpretBank saves all your glossaries in a single PRIVATE database on your computer (note that the Enterprise edition can also connect to a central MSSQL server database to allow users the access to a central repository of data).

Your personal data, such as glossaries, documents, etc. is saved in an application folder called InterpretBank6 which is created at installation time in the following locations:

  • Windows: either C:/users/YourAccount/AppData/Local or ProgramData
  • macOS: UserAccount/Library/Application Support

Glossaries are organized by their Name. If desired, a Glossary can be divided into SubGlossarys.

When you open a glossary, this will be the MAIN Glossary for your current session. If you are creating or editing a glossary, the MAIN Glossary is the place where new terms will be saved. If you are in the Booth view and look up terms, the MAIN Glossary will be the first place where InterpretBank will search for translations.

How to create a new glossary

To create a new glossary, follow the steps described in Create a new glossary. To help you while populating a glossary, InterpretBank can: suggest you a translation for a given term, automatically generate a list of specialized terms about your topic, automatically extract terminology from your preparatory texts, and many other features!

How to look up a glossary

You can look up your glossaries in different ways.

In the EDIT modality: use the search field on the top part of the interface. By default, only terms inside the MAIN glossary will be searched. You can search in your entire database by setting this in the search field menu.

In the BOOTH modality: use the search field with intelligent search features situated in the lower part of the window. Normally you will have a MAIN glossary open (the glossary related to your event), but you can also activate other glossaries. Depending on your BOOTH settings, InterpretBank will look up terms in the following order:

  • in your MAIN Glossary
  • in your MAIN Glossary AND in OTHER SELECTED glossaries (which are typically related to your assignment)
  • in your MAIN Glossary AND in your ENTIRE database
  • in your MAIN Glossary AND in your ENTIRE database AND in the reference terminology resources (like IATE) which we call AUTOMATIC TRANSLATION (because these resources have not been created by you).

The way this PROGRESSIVE search is performed can be customized by the user. The default BOOTH preferences will offer you a good starting point. Refer to the section In the booth to learn more.

Installation

Follow these instructions to install and update InterpretBank on Windows and macOS. On iPad on Android devices you do not need to install InterpretBank. You can access your glossaries through your Cloud Account with your favorite Browser.

Install on Windows

Download the installer from our Webpage and double click it. The first time you run InterpretBank it may require a bit of time to start.

Some Antivirus may not recognize InterpretBank and prevent its installation. In this case, add an exeption to your antivirus. Please report this to our service (info@interpretbank.com) so that we can prevent the same to happen in future.

Update on Windows

If the option Automatic search for updates in menu Options | Preferences | General is activated, InterpretBank will automatically notify you when a major update is available. You can also check manually for minor updates using menu Help | Check updates. When you confirm the notification of an available update, follow the instruction on screen to update your installation.

We advise you to perform a backup of your database before updating InterpretBank.

Install on macOS

Download the image from our Webpage and move the App in the Application folder.

Update on macOS

If the option Automatic search for updates in menu Options | Preferences | General is activated, InterpretBank will automatically notify you when a major update is available. You can also check manually for minor updates with menu Help | Check updates. When you confirm the notification of an available update, the update will be automatically downloaded. Run the downloaded .dmg, move the App in the Application folder and confirm the overwriting of your installation.

We advise you to perform a backup of your database before updating your installation.

Synchronize database between two computers

You can use InterpretBank on 2 different computers using the same Freelance license key. To do so, you need to synchronize your database between the two computers, i.e. using the same database on both. One advantage is that you will have the same database, i.e. the same glossaries on both computers. Follow these instructions step-by-step to synchronize and activate your license on 2 computers. Please note that you should synchronize databases only among the same OS (Windows+Windows or macOS+macOS). Any other combination may work, but is not officially supported. To prevent any loss of data during set up, perform a database backup before doing the following steps:

First of all, choose a cloud service of your choice, for example Windows OneDrive or DropBox, and:

on your 1st computer

  • install InterpretBank and activate your license key (if not done before)
  • go to menu Options | Preferences | Private database
  • click on Move private database to cloud directory
  • choose the folder on the cloud directory in which you want to move your database. . Make sure the path does not contain characters other then Latin ones. Your database will be moved to this location
  • on your 1st computer your database is now in this folder. As this folder is synchronized by the cloud service of your choice, you can use the same database on the second computer

on your 2nd computer

  • be sure you have the same cloud service installed on this machine and check if you can see your database in its folder structure. Make sure the path does not contain characters other then Latin ones. You will need to tell InterpretBank to use this database
  • install InterpretBank, start it and set your language combination
  • got to menu Options | Preferences | Private database
  • click on Select private database in cloud directory
  • find your cloud service folder, select the database you have moved from your first computer
  • InterpretBank will connect to this data and start working with the synchronized database. You can now insert your license key and activate this installation

Note that the synchronization is performed by the cloud service provider of your choice, not by InterpretBank. Refer to its manual to know how synchronisation works. When you are connected with the Internet, the synchronisation is normally done automatically by the cloud service any time the database is updated.

Please note that using a synchronisation service such as DropBox or oneDrive you accept their Terms and Conditions. You can also think of using a private Cloud (see for example: MyCloud Mirror by WD).

Proxy

Normally InterpretBank is able to automatically read the settings if your computer is behind a proxy. If this is not possible and you are not able to connect to the Internet, you can set manually the proxy with the following instruction:

  • go to menu Options | Preferences, tab Advanced.
  • in field Address (older version Domain), enter your proxy values in the format proxy.example.com:80.

License

With a personal license key, you can activate InterpretBank on up to 2 desktops/laptops sharing the same database. This means that your data will be synchronized between the two installations. See Synchronise database to learn how to share the same database between 2 computers by means of a cloud service.

Activate your license

After installing InterpretBank, you can enter the license key in menu Help | License. Press the Activate button to register the license online and activate it (Internet connection required).

Deactivate your license

If you buy a new computer and want to move your installation to the new computer or if you reformat your computer and need to install InterpretBank on the same machine again, you need to deactivate your license key from the old machine. This will return the license to the license management server so that you can reuse it to activate a new installation. You can deactivate your license in menu Help | License. This operation requires an active Internet connection. After this operation, you can activate your license again on the new computer.

Organize Glossaries

In this section you can learn how to organize your glossaries, how to create a new glossary or how to delete, rename and modify an existing glossary.

Create a new glossary

Your terminology is organized in glossaries and saved in a database stored on your computer. Inside a glossary you can have subglossaries. The use of subglossaries is not mandatary and depends on the way you like to organize your terminology (i.e. you could decide to have a glossary for your customer "Mercedes" and have subglossaries inside the "Mercedes" glossary such as "brakes"/"marketing"/"clutches").

To create a new glossary:

  • Select menu Glossary | Create new glossary or click the icon . A dialog will be shown.
  • Enter the name of your new glossary in Glossary.
  • Set the languages of your new glossary (you can add other languages at any time).
  • You can add a description about the glossary in Notes about this glossary, for example some notes about the event, organizer, etc.
  • If desired, select a set of tags to tag your glossary. The tags can be defined in menu Options | Preferences | Tags.
  • Click Create. Note that you can not create a new glossary with the same name of a glossary already saved in the database.

Your new glossary has been created. Its name will appear in the top part of the main window. This indicates that the glossary is open and ready to be populated.

TAGS

You can add Tags to each glossary in order to select them for example in the Booth view. Tags need to be defined at the database level. To do so, click on the button Add new tags in the New Glossary Wizard, or open menu Options | Preferences | Tags. Add one tag per line. When you have defined your Tags, you can activate them while you are creating a new glossary.

Create a subglossary in an existing glossary

To create a Subglossary inside an existing Glossary, proceed as follows:

  • Open an existing glossary.
  • Select menu Glossary | Create new subglossary.
  • Follow the same instructions to create a Glossary.

Open a glossary

To open a glossary or a subglossary, select menu Glossary | Open main glossary or click on . A dialog will be shown. On the left you can select the glossary, on the right a subglossary contained in the selected glossary (if available). Make your selection and clic on Open.

Use the search field to search in the Glossary list. You can move up and down the list using the keyboard arrows. When a glossary or a subglossary is highlighted, the languages available in that glossary/subglossary will be shown in the lower part of the dialog. The same applies for the Tags you have associated to the glossary.

Note

If your glossary contains subglossaries and you do not specify a subglossary to be opened, ALL subglossaries will be opened

Rename a glossary/subglossary

Open the glossary/subglossary you want to rename, select menu Glossary | Rename/modify glossary or Subglossary | Rename/modify glossary and change the glossary name. Click on Create.

Delete a glossary/subglossary

Open the glossary/subglossary you want to delete, click on menu Glossary | Delete glossary or Subglossary | Delete glossary and confirm the message.

Note

If you delete a glossary, all contained glossary will be automatically deleted!

Merge two glossaries

Merging two glossary means to move all terms saved within a glossary into another existing glossary. Open the glossary you want to merge (first glossary), click on menu Glossary | Merge glossary. A Dialog window will appear. Select the glossary in which you want to move the terms of the first glossary. All terms will be moved into the second glossary.

Delete duplicates from a glossary

To delete duplicates inside a glossary, click on menu Glossary | Delete duplicates in selected glossary. This function will automatically delete perfect duplicates from the selected glossary.

Find duplicates in your entire database

To find duplicate entries in your database, go to menu Options | Preferences, tab "Private Database" and click on Find duplicates in entire database. A list of all duplicates will be shown in the table. The table will show all languages managed with InterpretBank and the glossary name of each entry. To delete duplicate entries, select a single row or multiple rows from the table and click on the icon Delete.

Note

Duplicates are not always something negative. In fact, you may want to have the same term in more than one glossary. For this reason, when you are in the both, in order to reduce the number of results, InterpretBank will automatically hide duplicate entries from the list of a search result.

Adding a language to an existing glossary/subglossary or changing the glossary languages

To add a new language to an existing glossary, open the desired glossary and click on menu Glossary | Rename/modify glossary. In the window you can add or hide the desired language(s).

Change order of columns

The columns order can be changed permanently (it will apply every time you open the glossary) or temporarily (only for the current session).

To change it permanently, open the glossary and click on menu Glossary | Rename/modify glossary. Using the drop-down menus you can modify the order of the languages. Note that the first two columns must be selected. This setting will apply also when you reopen the glossary.

To change it temporarily, open the glossary and right click with the mouse on the column of the table you want to move. Click on the desired command to move the selected column left or right . This setting will be applied until you reopen the glossary.

Show extra fields in table

In the table it is possible to show extra information beside the term and its translation(s).

Open a the glossary and right click on the table. Activate the field Show BoothInfo and/or Show glossary name. This setting will apply also when you reopen the glossary.

To show these columns temporarily, open the glossary and click on menu View | Change glossary visualization. Choose the info you want to see. You can activate BoothInfo, Glossary name/source and Abb.

  • BoothInfo: extra column containing a combination of the fields NotePad and Note (see Note box below for more information)
  • Glossary name/source: extra column containing the name of the glossary in which the term is contained or the source if the translation comes from an external/automatic source
  • Abb: the content of the field Abb (abbreviation) is added into the Term field

Note

In order to keep the table readable, the quantity of text shown in the column BoothInfo will be automatically cut at a fix length (default 500 characters). You can change this setting in menu Options | Preferences | Interface with the parameter Max length (char) of column BoothInfo.

Edit a glossary

In this section you will learn how to edit a term, find translation suggestions and improve your glossary creation experience.

Write and modify terms

Terms and their translations are edited in the Term fields in the upper part of the window. In addition to the term and its translation, you can add additional information, like a Definition or an Abbreviation, in the Extra fields and in the Notepad. You can show or hide these fields in menu View.

To edit a record you may use the following icons:

  • Save term: Click on this button to save a new record inside the open glossary or to update a record you have selected in the table (the record will be highlighted in the table). You can perform the same action by clicking on the Enter key .
  • Delete term: Select the record in the Table and press this icon to delete the term from your database. The action can not be undone after you confirm the next window.
  • Clear mask: clear all entry fields without deleting the record itself from the database. Use the Clear icon to deselect a previously selected record and be ready to enter a brand new term.
  • Translate: get a translation suggestion for the missing term(s) in the selected table row.

User Interface on Windows

Note on duplicating a record

If you want to duplicate a record already saved in your glossary, maybe because you want to modify some part of it but want to save it in a different record, click on the record in your table, modify it and save it with the shortcut ctrl/cmd+z.

Search a glossary or the entire database while creating a glossary

In the Edit modality you can search for a term in the open glossary or in the entire database by entering the term (or part of it) in the search field shown in picture and pressing the Enter key.

By default the search is done in all languages and only in the opened glossary. If you want to search in all your glossaries (entire database), click on the icon with three points and select where the search should be performed.

To look up terms in the booth, switch to the Booth modality using this icon . The booth modality implements an intelligent search system developed for interpreters.

Enter information in the extra fields and Notepad

To add additional information, such as definitions, abbreviations, etc. you can use 3 extra fields: the Note and Abb fields and the Notepad.

To show/hide these fields, use the two small icons on the right of the menubar.

In the Notepad you can add any kind of information. This information can be of any length. However, when this field is displayed in the table, in order to improve readability of the table itself, the length of the text shown is automatically cut down. The default value is 500 characters. You can change this length in "Max length (char) of column BoothInfo" available in menu Options | Preferences | Interface. To show this information in the table you need to explicitly tell InterpretBank to do so: right click of the mouse on the table and select the info you want to show.

Abbreviations: the best way to store abbreviations is to insert them in the field Abb. The abbreviation will be shown in the table togheter with the term. To show the abbraviations, right click on the table and select Show content of field Abb in table.

Extra fields

Get translation suggestions during glossary creation

You can get translation suggestions in 2 ways. They differ in the way the user interacts with the tool and in the resources available:

INSIDE InterpretBank

With this features translations are proposed directly in InterpretBank. You can easily choose the best translation and save it in your glossary.

  • enter a term in one language in the Term field
  • start the translation process by
    • pressing the function key F1 in Windows or Cmd+1 in macOS
    • pressing the icon
    • right clicking on a term field and selecting "Translate missing term"

A pop-up window will appear below the entry field that is missing the translation. Highlight a translation (you can use the arrows Up/Down of your keyboard), in the box below you will see information about the highlighted term. To confirm your choice, press the Enter key. If you do not find a suitable translation, simply click in the empty entry field to close the pop-up window or click ESC.

When all translations have been inserted, you can save the entry with the save icon or the shortcut Ctrl+s (Windows)/Cmd+s (macOS).

The information box contains the following information:

  • Score: this reflects the frequency of the highlighted suggestion in the available resources
  • Sources: a list of resources proposing this suggestion
  • Examples: sentences containing this suggestion from your preparatory documents (if you have added documents to your glossary). This may help you to choose the best suggestion.

If your glossary has a list of terms without translation, you can automatically translate all terms with function key F4 in Windows or Cmd+4 in macOS. Note that the translation needs to be manually validated.

In YOUR WEB BROWSER

With this features, translations are proposed in your default Web Browser. Enter a term in the entry field or select a table row which miss a translation, right mouse click and select Search translations/definitions in favourite Webpages; or use the function key F2 in Windows or Cmd+2 in macOS. Your default Web browser will be opened with the results for your language combination. You can setup this function in tab "Results shown in Web Browser" available in menu here. As results are shown outside InterpretBank, to add a translation to your glossary you need to copy and paste it. You can activate your favourite resources in menu Options|Preferences|Translation resources (see Translation resources).

Generate a list of specialized terms about your topic

InterpretBank can automatically generate a list of terms in one language related to a specific subject. This may help you starting to create your glossary, for example when it is the first time you work on this subject and you do not receive preparatory documents from your client. The terms are supposed to be typical of that domain and highly interesting for your preparation and glossary creation. Note that not only specialized terms will be collected, but also entities (names of persons, places, etc.) that are someway related to the topic.

How to generate the term list with method ONE (available in the freelance edition)

  • Open an existing glossary or create a new one. Click on menu Tools|Collect terminology from Web.
  • Insert a term describing your subject, for example 'nuclear power' or 'climate change' and select the language, in our example 'English'. Do not use '' to mark your terms. Please note that you should indicate a single term (made of one word or n-words), not a collection of terms. To use a collection of terms to define your topic, you need to use method TWO (see below).
  • Click on Collect terminology.
  • A list of terms will be collected and shown. If InterpretBank needs to disambiguate your search, it will present you with a selection of meaning that it things that may better define your search. The number of terms selected depends on language and topic, and can typically vary from 20 to 400 terms.
  • Select the terms you want to import into your glossary. Set if InterpretBank should try to find definitions for each term (definitions are saved in the field Note-bloc) and if it should automatically translate the entire glossary. Please note that the collection of definitions and translations may require some time.

Generate a list of terms from a webpage

InterpretBank can automatically generate a list of terms from almost any website. Proceed as follows:

  • Open an existing glossary or create a new one. Click on menu Cloud | Collect texts/terms from webpage.
  • Insert the domain of the webpage you are interesed in, for example www.spacex.com
  • Select the language of the webpage.
  • Click on Download.

This process may take some time. Please wait.

After the download process has been performed, switch to the Documents modality. Select the tab with the language of interest. You will see that a document with the name of the domain has been added. Click on the terminology extraction icon and select the profile of extraction you prefer.

Documents

Add your preparatory documents to a glossary, extract the terminology, both manually and automatically.

Adding documents

Open the Documents modality by clicking on the icon .

You can add documents in the formats .pdf, .doc, .docx .odt and .pptx.

To add a document:

  • select the tab corresponding to the language of your document, click on the icon and browse to the document location. You can also Drag&Drop the document in the left box. An automatic check will print an error if the document's language does not correspond to the tab's language.
  • click on menu Add preparatory documents to glossary, select one or more file and click on Open. The document(s) will be automatically imported into the right tabs (language) according to their language

A copy of the document will be saved in the Personal data folder associated with InterpretBank (you can move the default folder in menu Options | Preferences | Documents). InterpretBank will import the document. This may take some time depending on the length of the document.

Note

not all documents can be read by InterpretBank (and by any other computer application), for example the PDF files produced by scanning documents require OCR, which is not available in the Freelance version. In this case the imported document will be empty and an error message will be shown.

The list of available documents connected to your glossary is shown in the left pane. From this list you can click on the following icons of the menu bar:

  • add a new document to the glossary.
  • delete the selected document from InterpretBank (the original file in its original location will not be deleted).
  • pop up to choose to open the document inside InterpretBank or to open it in its original application (standard PDF Viewer and MS Office/PowerPoint).
  • extracts relevant terminology from ALL documents saved in the selected language tab.
  • ParScroll activate parallel scrolling of all opened documents. Parallel scroll works only if documents are moved by using the vertical bars.

Working with a document

From the documents list, open a document in InterpretBank.

With a document you can:

  • highlight and insert a term in the entry mask: simply highlight the desired term. The highlighted term will be automatically inserted in the right language of the entry mask. Now you can save the term. Before saving the term, however, you can edit it, enter a translation manually, or search for a translation pressing the function key F1 in Windows or Cmd+1 in macOS. When you have finished to edit the record, save it by clicking on the icon .
  • highlight and save a term in the glossary: highlight a term in the document, right click of the mouse and select Save in glossary. The term will be automatically saved in the glossary without further editing.
  • see how the term is used in your documents: highlight the term, right click of the mouse and select Search in my documents. A window with the occurrences of the term in all the documents saved in the glossary will be shown.
  • search a term in Google: highlight the term, right click of the mouse and select Search in Google. Your Browser will be opened and Google results will be shown.
  • search a term in Google Images: highlight the term, right click of the mouse and select Search images in Google. Your Browser will be opened and Google results with images will be shown.
  • highlight all terms of interest and insert them in the glossary in one go: you can highlight all terms that are relevant in your document and import them in one run. Click on to activate multiple selection, select all terms of interest, click on to import them in your glossary. To deselect a term, just right click on it and choose Remove selection.
  • Annotate your document
    • Annotate text with translations from glossary: the terms available in your glossary will be highlighted in the document and translations will be added to the document
    • Highlight interesting monolingual terms automatically: relevant terminology in the document will be automatically highlighted.
    • Highlight interesting monolingual terms automatically (SMART): relevant terminology in the document will be automatically highlighted. Intelligent algorithms will improve the quality of extraction and personalize it according to your past actions.
    • Annotate text in Browser with translations from glossary: the text will be opened in your default Browser, the terms available in your glossary will be highlighted in the document and translations will be added to the document.

Manual term extraction from single documents

Open a document inside InterpretBank (see Working with a document). There are two modalities to highlight terms and insert them into the glossary:

  • single terms: simply highlight the desired term. The highlighted term will be automatically inserted in the right language of the entry mask. Now you can save the term. Before saving the term, however, you can edit it, enter a translation manually, or search for a translation pressing the function key F1 in Windows or Cmd+1 in macOS. When you have finished to edit the record, save it by clicking on the icon .
  • highlight all terms from a single document and insert them automatically: you can highlight all terms that are relevant in your document and import them in one run. Click on to activate multiple selection, select all terms of interest, click on to import them in your glossary. To deselect a term, just right click on it and choose Remove selection.

Manual term extraction from parallel documents

If have two parallel documents (original language + translation), you can open both texts and easily spot your terminology in both languages. How it works:

  • highlight the terms in both languages
  • the terms are automatically inserted in the glossary
  • save the new term

You can activate ParScroll to parallel scrolling all opened documents. Parallel scroll works only if documents are moved by using the vertical bars.

Automatic term extraction from a set of documents

This function, available for English, French, Spanish, German, Italian, Dutch, Polish, Russian, extracts the monolingual terminology from all the texts you have saved in your glossary.

Click on the icon . Choose your term extraction algorithm:

  • Extract terminology with abbreviations: this is the basic extraction modality. Terminology and abbreviation will be extracted using only the documents as knowledge base.
  • Extract terminology with abbreviations (SMART): this is the advanced extraction modality. Terminology and abbreviation will be extracted also using the past actions performed by the user. The more you use the software, the more customized the extraction will be. With this modality, terms selected as non interested, terms that have been already translated, and so forth will not be shown among the results. This modality is particularly useful if you work very often with similar topics.
  • Extract only abbreviations: only abbreviations will be extracted

The results are shown in a table with pages of 25 results each. You can move forward and back using the paging functionality on top. With each term in the result list you can:

  • Insert the term into the mask for editing
  • Insert the term into the mask and find a translation
  • Search the term in the preparatory documents to understand the context of use
  • Mark the term as "not interesting to me". InterpretBank will learn from this choice in future extractions.

For each page you can select also multiple terms and:

  • Insert all selected terms into glossary and save them
  • Insert all selected terms into glossary, save them, and mark all non selected terms as "not interesting to me". InterpretBank will learn from this choice in future extractions.

Note

The quality of extraction depends on several factors:

  • the quantity of documents and their length; term extraction works best if you have many/long texts (if you have only one short text it is probably best to read it and extract the terminology manually).
  • the level of specialization of the texts. Use it for specialized texts.
  • the machine readability of the documents: some documents can not be processed/read by computers (for example Scans). You can see how good/bad a text has been processed opening it inside InterpretBank. If the text does not appear like a normal text, but the sentences or, for example, the words are broken up in more lines then the quality of the extraction will suffer. In this case, please delete the text if it affects the quality of the terminology extraction.

Automatic download of EUR-lex legislation

This function has been designed primarily for interpreters working with the EU institutions or dealing with the legislative texts of the EU. It allows to automatically download legislation texts from theEUR-lex by inserting the CELIX number of the document. InterpretBank will download all language versions available for your language combination (opened glossary) and save them in your glossary. You can then process the texts using the methods described in section Documents. To download a set of texts from Eur-lex:

  • Open your glossary or create a new one
  • Open the Documents mode
  • Go to menu Cloud | Download EUR-lex document, insert the CELIX number and click on Download

Term in context

With this function you can see how a word is used in your preparatory documents. You will get all occurrences of the word in the documents saved within the opened glossary. You can access this function in menu Glossary | Open concordancer or by highlighting a word in a term field, right clicking of the mouse and choosing Search in my documents in the popup menu.

In the concordancer window, you can enter a word, select the language, and start a search. Note that you need texts saved within the glossary to display results. If you want to search for exact matches, please enter the word within "".

Memorization

The Memorization modality is the feature to visually memorize/rehearsal your glossaries before an event. It is based on a simplified "Leitner system", a widely used method of efficiently using flashcards that was proposed by the German science journalist Sebastian Leitner in the 1970s. It is a simple implementation of the principle of spaced repetition, where cards are reviewed at increasing intervals. To open this mode, open the glossary you want to memorize and click on . You can also use it on mobile device, for example on your iPhone, read here.

Memorizing a glossary on the computer

  • Open a glossary (if a glossary has more languages than what you want to learn, change the table visualisation by right clicking the mouse on the table and hide the languages you do not need). Switch to the Memorisation modality
  • Start Manual (Start) or with Automatic advancing (Play). To set the speed of the automatic advancing, use the ruler.
  • Activate Speak! if you want InterpretBank to read aloud the terms in the source language and, if you wish, in the target languages too (activate Only source if you want to be read aloud only terms in the source language).
  • With the manual modality, advance the cards with the buttons on top, choose between KNOWN if you knew the answer. Click on FORGOT if you do not know it. InterpretBank will keep track of this. When you will learn the same glossary in the future, you will be asked first the terms you had more problems with.
  • To swap the first two languages, click on Invert
  • To shuffle the order of appearance, click on Invert

Note

Note that the language packages for the given language must be installed on your system. Read how to install missing voices for Windows 10 and macOS.

Memorizing a glossary on a mobile device

To memorize a glossary on a mobile device, such as an iPad, please click here.

In the Booth

The conference modality is the feature designed to intelligently search for terms in the booth. To open this mode, click on . Beside searching your glossaries on your Windows/macOS computer, you can also do it on any mobile device, such as iPad and Android tablets, uploading one or more glossaries to our secure server (see iPad/Android).

Introduction

The Conference modality has been developed to perform searches in one or more glossaries in a booth-friendly way. The standard settings should be okay in most cases. However, you can influence the way InterpretBank works, changing the settings in Options | Preferences | Booth .

There is not a "best" setting; it just depends on how you prefer to use the tool. We encourage you to try different settings before using the tool in the booth and getting accustomed at how searches are performed with your personal settings.

How your database is searched

In the Conference modality, InterpretBank can search in a customazible variety of resources. You can decide where the tool should search in Options | Preferences | Booth. With InterpretBank you can search:

  1. MAIN glossary (the glossary that you have opened in the InterpretBank's interface);
  2. MAIN glossary and in a set of EXTRA glossaries (MAIN glossary and EXTRA glossaries will form what we call the EVENT glossary);
  3. ENTIRE database (i.e. all your glossaries);
  4. EXTERNAL resources, like the integrated IATE database.
  5. AUTOMATIC resources, like online databases.

To customize this search behaviour, see menu Options | Preferences | Booth.

Open a glossary

To open a glossary, click on the icon and select the desired glossary or subglossary. This will be your MAIN glossary.

Activate more than one glossary

To open other glossaries on top of the MAIN glossary, you can open other glossaries by their name or by tags associated to the glossaries.

Open other glossaries by name

In the Conference modality click on the icon , click on Add more glossaries by name or click on menu Booth | Add more glossaries by name. A pane with all your glossaries will be displayed on the left part of the table. Select all the glossaries you want to activate in your current session.

Open other glossaries by tags

In the Conference modality click on the icon , click on Add more glossaries by tags or click on menu Booth | Add more glossaries by tags. A pane with all your glossaries will be displayed on the left part of the table. Select all the glossaries you want to activate in your current session.

Note

Select when InterpretBank should search your entire database. Default option is "If no result is found in selected glossary(s)" (meaning MAIN glossary and other selected glossaries). This is particularly helpful if you do a search and nothing is found in your selected glossaries. InterpretBank will search in your entire database. You can extend this search also to external resources (such as your local copy of IATE) or to online resources. You can set this in menu Options | Preferences | Booth

Search also in online resources

In menu Options | Preferences | Booth you can set if InterpretBank should query the Internet to find translation candidates. We advise you to extend the search to online resources only if no useful translation is found inside InterpretBank. Searching online requires sometime (similar to loading a webpage in your Browser) and not pre-edited results, such as the terminology in your database, may not be helpful for your context. Interpreting in real-time, you do not have time to check for the quality of the translation. However, this could be very useful if you are not interpreting live, for example your when boothmate is interpreting.

Change information shown in table

To change the information shown in the table, right click of the mouse on the table and select the information you want to show.

Updating/Adding terms on-the-fly

To update a term from in Booth modality, select a row in the table, right click of the mouse and choose Update selected term. A dialog window will be displayed. Update your term and click Apply.

To add a new term from the Booth modality, right click on the term on the table and choose Add term to main glossary. A dialog window will be displayed. Add your term and click Save.

Note

Note that the term will be added to the main glossary you have opened, i.e. if you have opened more than one glossary, it will be added to the first glossary you have selected from the Open Wizard.

Import/Export, Print, Backup

In this section you can learn how to import a glossary into InterpretBank, how to export and how to print a glossary. You will also learn how to backup your database.

Exchange a glossary between InterpretBank's users

Exchanging glossaries between users of InterpretBank is straightforward. To export a glossary (the format used is standard .tbx), open your glossary, then select menu Glossary | Export glossary | INTERPRETBANK (.tbx). Select the folder where you want to save the file and save it. Now you can forward the file to your colleague.

To import into InterpretBank a .tbx file received from a colleague, select menu Glossary | Import glossary into database | INTERPRETBANK (.tbx). InterpretBank will automatically import the glossary. If the .tbx file contains languages you do not manage in in InterpretBank, InterpretBank will skip them.

Export Excel/Word

Open the glossary you want to export, then select menu Glossary | Export glossary | Excel or Glossary | Export glossary | Word (table)/Glossary | Export glossary | Word (book). Select the folder where you want to save the file.

Import Excel, MS Word and ODT

You can import glossaries stored in spreadsheets such as Microsoft Excel (.xls and .xlsx) and OpenOffice (.ods) as well as in text such as Microsoft Word (.doc and .docx) and Open Office (.odt).

To import a glossary, proceed as follows:

  • In InterpretBank, open an existing glossary (the one in which you want to import your data into) or create a new empty glossary.
  • Click on menu Database | Import glossary into database | EXCEL or WORD and select your file.
  • In Import preview you will see your glossary as it will be imported in the database. InterpretBank will try to detect the languages of each column. Please check if InterpretBank has selected the right language for each drop-down menus. If not, correct the selection. Each drop-down menu should show the right language for the corresponding column. If a column should be skipped, please select "Skip".
  • Select the option Exclude first row to exclude the first row of your glossary (useful if this row contains the language names). If this option is selected, the first row will not be imported.
  • Insert the name of the glossary (and of the subglossary, if you wish).
  • Press Import to import the file.

Note

Note for EXCEL: only the first sheet of your Excel file will be imported.

Note for WORD: please note that the glossary must be contained in a simple table; as Word files are not the ideal format to save structured data (such as a glossary), depending on the structure/formatting of your Word file, InterpretBank may have problems importing the glossary. The import works better with modern .docx files. We advice you to upgrade your .doc file into a .docx file using your MS Word program.

Note for OpenOffice: OpenOffice glossaries can not contain the caracther ";". Please substitute this character in your OpenOffice file before importing it.

Print

To print a glossary, open your glossary, then select Glossary | Print via Browser. The glossary will be displayed in your default Internet Browser. Use the print option of your Internet Browser to print the glossary.

The glossary will be displayed in the language and alphabetic order as shown in InterpretBank. To change the order of your terms, click on the table header of InterpretBank; if you want to change the column order, change it in menu View|Change glossary visualization. When the glossary is visualized as you desire, use the procedure described above to open your glossary in your Internet Browser and print it.

Backup

To backup the database, select Database | Backup | Backup personal data. Choose the folder where you want to save a backup copy of your database. Your database will be renamed with the current day and saved in this location.

To restore your database from a backup, select Database | Backup | Restore personal data. Specify the backup database you want to restore. This file will overwrite your current database. A copy of your current database will be automatically saved in your Personal folder.

Data visualization

Learn the available options to visualize a glossary.

Order your terms in the table

Normally, the terms of a glossary are displayed from newest term (top) to oldest one (bottom). You can change this in menu View | Order of results. If you wish to order the results alphabetically in one language, just click the language name in the table header.

Show/Hide information in the table

It is possible to change the amount of information shown in the table to fit user's needs. To do so, click with the right button of the mouse in the table. A pop-up will appear. Here you can:

  • Show/Hide the column BoothInfo: in this column you will find the content of the fields Info and NotePad. Note that in order to grant usability of the table, the information inserted here will be cut to a fix number of characters (default 500). You can change this value in menu Options | Preferences | Interface.
  • Show/Hide the column Glossary name: in this column you will find the source of the record. This can be the glossary name or the source of an automatic translation.
  • Show the content of field Abb: activate this option to show your abbreviations in the table.

Change order of language columns

To change the order of the column in the table, right clic on a column in the table. A pop-up window is displayed. Select in which direction to move the column.

Change languages shown in table

To change the languages shown in the table, for example in the case a glossary contains 3 languages but you are going to use only 2, right clic on a the column you want to hide. A pop-up window is displayed. Select Hide colum. The column is hidden only for the current session and will be displayed again when you reopen the glossary.

Note

To reset the original languages of the glossary, right clic on the table and select Show default languages defined for this glossary.

Private Cloud Account

Learn how to lookup, modify, memorize and share your glossaries online.

Introduction

With InterpretBank you normally create your glossaries on your computer using all the advanced functionalities of our tool. Your database is saved locally on your computer. If you desire, you can upload one or more glossaries to your Private Cloud Account. From there, you can access your glossaries from any device, for example an iPad, a mobile phone, etc. You access your Private Cloud Account using your Internet Browser and looging in from this address www.interpretbank.eu/cloud.

After logging in, you will be in your Dashboard. Here you will see a list of all uploaded glossaries. You can access single glossaries for lookup or memorization. You can also share a glossary with your colleagues, giving them read-only access (they will be able only to look up the glossary without modifying it) or read-and-write access (they will also be able to modify the glossary). In this way you can create and edit a glossary in a team.

If you want, you can share a glossary with the community professional interpreters and publish it on the GlossaryBank. The GlossaryBank is the place to share glossaries with other people (the community). Glossaries shared on the GlossaryBank become public. You can decide to public your name and your webpage address with your glossary and gain visibility.

Login

To log in into your Personal Cloud Account go to www.interpretbank.eu/cloud.

Privacy

The glossaries uploaded on your Personal Cloud Account are private and are not shared with anyone! Confidentiality is paramaunt for InterpretBank.

Create a Private Cloud Account

To use your Private Cloud Account you need to create it. You do it directly from InterpretBank Desktop. Proceed as follows:

  • Go to menu Cloud | Create/Manage Cloud account
  • Enter the desired login crdentials: Username, Password and a valid E-mail
  • Click on Create cloud account
  • Confirm the terms and conditions by clicking on Accept Terms and Create Account
  • You can now access your Private Cloud Account at www.interpretbank.com/cloud using your Username and Password

Upload a glossary to the Cloud Account

To upload a glossary from your computer to your Private Cloud Account, open the glossary in InterpretBank Desktop and go to menu Cloud | Upload glossary to my Private Cloud Account. The glossary will be uploaded and will be available in your Dashboard.

Download a glossary into InterpretBank (Desktop)

You can download a glossary from your Personal Cloud Account (for example if you have modified the glossary online) or from the GlossaryBank into your desktop application. To download a glossary from your Personal Cloud Account, locate the code associated with the glossary and enter the code in InterpretBank's menu Cloud | Download glossary from your Personal Cloud Account. Your glossary will be automatically downloaded and added to your database.

You can download a glossary that is available the GlossaryBank. locate the code associated with the glossary and enter the code in InterpretBank's menu Cloud | Download glossary from GlossaryBank.

Note

If you download a glossary from your Personal Cloud Account (because you have modified it), you need first to manually delete your old glossary from InterpretBank and then download the newer version from the Cloud.

ATTENTION: note that up to version 7.14, only Term fields are imported back into your deskop application. This means that if you have uploaded a glossary containing extra information (in the extra fields), if you delete your glossary, these info will be deleted. A solution fixing this issue will be available soon! From version 7.15 all fields are imported back into the Desktop application.

An automatic synchronisation will be implemented in the next months.

Dashboard

In the Dashboard you can access your uploaded glossaries.

All your uploaded glossaries are listed in a table. You will find some information, such as glossary name, languages, date of creation, and a pop-up button to do several actions with your glossaries:

  • Lookup (only): open the glossary for lookup in a read-only way
  • Lookup+Edit: open the glossary for lookup and edit
  • Memorize (classic): open the glossary for memorization in a classic flash card app
  • Memorize (swipe): open the glossary for memorization in a modern swipe app. You can set a mood (enter a word such 'sun', 'seaside', 'rain') to change the appearance of the cards. The right mood my help you better memorize the terms. This app has been designed for mobile phones.
    • Tap on card to see the translation
    • Swipe left if you do not know the term
    • Swipe right if you know the term
  • Share: send a link to a collegue to access your glossary
  • Delete: delete the glossary from your Cloud Account (this does not affect your Desktop version of the cloud)

Lookup multiple glossaries

You can lookup a single glossary or multiple glossaries. To lookup a single glossary, search it in the Dashboard table, click on Action and choose Lookup (only) or Lookup+Edit.

To look up multiple glossaries, click on "Open multiple". In the popup, select all glossaries you want to open and click on "Open glossaries". You can now show/hide the languages you want to use.

GlossaryBank

GlossaryBank is the place where people can share their glossary with the community.

Share your glossaries with the community. Access online the glossaries shared by the community. Download the glossaries shared by the community into your Desktop application and start using it on your computer.

Upload a glossary to your Personal Cloud Account. In the dashboard, locate the code of the glossary you want to share, click on Share a glossary with a collegue. Insert the mail of your colleague, the glossary code, and decide if you want the collegue to be also able to modify the online version of your glossary. Click on Send. Your collegue will receive a link to open the glossary on her webbrowser. This works without the need for your colleague to have InterpretBank or a Personal Cloud Account.

Share a glossary with your colleague

You can share your uploaded glossaries with your colleague. You can give them access only to a read-only version of your glossary or to a version where they can edit your glossary.

To share a glossary, click on "Share a glossary with a collegue", enter her e-mail, the code of the glossary you want to share, decide if you want to grant her also the right to edit your glossary, and click on "Send". Your colleague will receive an e-mail with a link to open the glossary on a Web browser.

Search a glossary in your Web browser

  • Looking up words is always accent insensitive
  • The search is done progressively while you are typing the term. On some Browser, this function is disabled. In this case, press the magnifying icon to start the search.
  • Press Enter to clear the search mask
  • In the menu on the left side, you can Show/Hide the column with the languages available in your glossary and toggle the Info column. The Info column contains the information saved in the fields Info and NotePad in your Desktop application.